Troubleshooting impossibility to add members or managers to Social Space

Problem

It may happen that some Social Space users are not able to add members or managers to Social Spaces. This can happens from the Social Space administration panel where when adding a user as a manager or approving a user as a member, an error message is displayed and no action is performed.

Causes

The user management policy deployed in Confluence can be the origin of this issue where using a read only mode based on an external user source blocks the possibility to add managers or members to the Social Space groups.

When creating a social space, two groups are created to manage the managers and members. The add-on perform actions to add/delete users from that group when performing add-on actions.

Resolution

There are some workaround to avoid this error:

  • Changing the user management policy. Even thought this is not common or advised, this can be considered as a solution.
  • Pass by space permissions management panel: You can emulate the Social Space behavior by adding individually the managers or users on the specified permissions of your space.

We advise you to contact our support team on labsupport@spectrumgroupe.fr to assist you on this task when this error is encountered.